Doc #67015 [NEW]: some Predefined Constants missing 'example'

From: Date: Thu, 03 Apr 2014 21:37:41 +0000
Subject: Doc #67015 [NEW]: some Predefined Constants missing 'example'
Groups: php.doc.bugs 
Request: Send a blank email to doc-bugs+get-11114@lists.php.net to get a copy of this message
From: joseph at cheek dot com Operating system: N/A PHP version: Irrelevant Package: Documentation problem Bug Type: Documentation Problem Bug description:some Predefined Constants missing 'example' Description: ------------ --- From manual page: http://www.php.net/class.datetime --- some of these examples show the text 'example' and some do not. It would make sense to make them consistent. witness: Predefined Constants ¶ DateTime::ATOM DATE_ATOM Atom (example: 2005-08-15T15:52:01+00:00) DateTime::COOKIE DATE_COOKIE HTTP Cookies (example: Monday, 15-Aug-05 15:52:01 UTC) DateTime::ISO8601 DATE_ISO8601 ISO-8601 (example: 2005-08-15T15:52:01+0000) DateTime::RFC822 DATE_RFC822 RFC 822 (example: Mon, 15 Aug 05 15:52:01 +0000) DateTime::RFC850 DATE_RFC850 RFC 850 (example: Monday, 15-Aug-05 15:52:01 UTC) DateTime::RFC1036 DATE_RFC1036 RFC 1036 (example: Mon, 15 Aug 05 15:52:01 +0000) DateTime::RFC1123 DATE_RFC1123 RFC 1123 (example: Mon, 15 Aug 2005 15:52:01 +0000) DateTime::RFC2822 DATE_RFC2822 RFC 2822 (Mon, 15 Aug 2005 15:52:01 +0000) DateTime::RFC3339 DATE_RFC3339 Same as DATE_ATOM (since PHP 5.1.3) DateTime::RSS DATE_RSS RSS (Mon, 15 Aug 2005 15:52:01 +0000) DateTime::W3C DATE_W3C World Wide Web Consortium (example: 2005-08-15T15:52:01+00:00) Test script: --------------- $ wget http://us1.php.net/class.datetime Expected result: ---------------- 'example' in all examples, or none, or an explanation as to why some have it and some don't -- Edit bug report at https://bugs.php.net/bug.php?id=67015&edit=1 -- Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=67015&r=trysnapshot54 Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=67015&r=trysnapshot55 Try a snapshot (trunk): https://bugs.php.net/fix.php?id=67015&r=trysnapshottrunk Fixed in SVN: https://bugs.php.net/fix.php?id=67015&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=67015&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=67015&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=67015&r=needscript Try newer version: https://bugs.php.net/fix.php?id=67015&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=67015&r=support Expected behavior: https://bugs.php.net/fix.php?id=67015&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=67015&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=67015&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=67015&r=globals PHP 4 support discontinued: https://bugs.php.net/fix.php?id=67015&r=php4 Daylight Savings: https://bugs.php.net/fix.php?id=67015&r=dst IIS Stability: https://bugs.php.net/fix.php?id=67015&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=67015&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=67015&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=67015&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=67015&r=mysqlcfg

« previous php.doc.bugs (#11114) next »