Doc #67015 [Opn->Csd]: some Predefined Constants missing 'example'

From: Date: Sat, 05 Apr 2014 05:24:02 +0000
Subject: Doc #67015 [Opn->Csd]: some Predefined Constants missing 'example'
References: 1  Groups: php.doc.bugs 
Request: Send a blank email to doc-bugs+get-11117@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=67015&edit=1 ID: 67015 Updated by: kalle@php.net Reported by: joseph at cheek dot com Summary: some Predefined Constants missing 'example' -Status: Open +Status: Closed Type: Documentation Problem Package: Documentation problem Operating System: N/A PHP Version: Irrelevant -Assigned To: +Assigned To: kalle Block user comment: N Private report: N New Comment: This bug has been fixed in the documentation's XML sources. Since the online and downloadable versions of the documentation need some time to get updated, we would like to ask you to be a bit patient. Thank you for the report, and for helping us make our documentation better. All of them already had an example, where 2 were without the 'example:' prefix and one being an alias, I've updated the manual for consistency Previous Comments: ------------------------------------------------------------------------ [2014-04-05 05:23:57] kalle@php.net Automatic comment from SVN on behalf of kalle Revision: http://svn.php.net/viewvc/?view=revision&revision=333269 Log: Fixed #67015 (some Predefined Constants missing 'example') ------------------------------------------------------------------------ [2014-04-03 21:37:41] joseph at cheek dot com Description: ------------ --- From manual page: http://www.php.net/class.datetime --- some of these examples show the text 'example' and some do not. It would make sense to make them consistent. witness: Predefined Constants ¶ DateTime::ATOM DATE_ATOM Atom (example: 2005-08-15T15:52:01+00:00) DateTime::COOKIE DATE_COOKIE HTTP Cookies (example: Monday, 15-Aug-05 15:52:01 UTC) DateTime::ISO8601 DATE_ISO8601 ISO-8601 (example: 2005-08-15T15:52:01+0000) DateTime::RFC822 DATE_RFC822 RFC 822 (example: Mon, 15 Aug 05 15:52:01 +0000) DateTime::RFC850 DATE_RFC850 RFC 850 (example: Monday, 15-Aug-05 15:52:01 UTC) DateTime::RFC1036 DATE_RFC1036 RFC 1036 (example: Mon, 15 Aug 05 15:52:01 +0000) DateTime::RFC1123 DATE_RFC1123 RFC 1123 (example: Mon, 15 Aug 2005 15:52:01 +0000) DateTime::RFC2822 DATE_RFC2822 RFC 2822 (Mon, 15 Aug 2005 15:52:01 +0000) DateTime::RFC3339 DATE_RFC3339 Same as DATE_ATOM (since PHP 5.1.3) DateTime::RSS DATE_RSS RSS (Mon, 15 Aug 2005 15:52:01 +0000) DateTime::W3C DATE_W3C World Wide Web Consortium (example: 2005-08-15T15:52:01+00:00) Test script: --------------- $ wget http://us1.php.net/class.datetime Expected result: ---------------- 'example' in all examples, or none, or an explanation as to why some have it and some don't ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=67015&edit=1

« previous php.doc.bugs (#11117) next »