#45328 [Ver->Csd]: post_max_size of 6144M of greater causes $_POST to fail
| From: | thiago@php.net | Date: | Mon, 21 Jul 2008 21:03:54 +0000 |
| Subject: | #45328 [Ver->Csd]: post_max_size of 6144M of greater causes $_POST to fail | ||
| References: | 1 | Groups: | php.doc.bugs |
| Request: | Send a blank email to doc-bugs+get-987@lists.php.net to get a copy of this message | ||
ID: 45328
Updated by: thiago@php.net
Reported By: corry dot gellatly at ncl dot ac dot uk
-Status: Verified
+Status: Closed
Bug Type: Documentation problem
Operating System: Linux (Fedora Core 8)
PHP Version: 5.2.6
Assigned To: thiago
New Comment:
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.
Thank you for the report, and for helping us make our documentation
better.
Previous Comments:
------------------------------------------------------------------------
[2008-07-15 02:46:39] jani@php.net
You're just hitting the limit of 32bit signed integer.
M in php.ini's is converted to 1024 * 1024 and 6144M == 6144 * 1024 *
1024.
Supported ini "helpers" are:
G = 1024 * 1024 * 1024 (giga)
M = 1024 * 1024 (mega)
K = 1024 (kilo)
------------------------------------------------------------------------
[2008-06-21 19:06:39] corry dot gellatly at ncl dot ac dot uk
Description:
------------
Setting post_max_size to a value of 6144M or greater causes $_POST to
fail, for example to log in and start a session with the simple code
below:
<?php
session_start();
$username = $_POST['username'];
$password = $_POST['password'];
...etc.
?>
It will also cause the login to phpMyAdmin to fail with the error
message:
Warning: Unknown: POST Content-length of 81 bytes exceeds the limit of
-2147483648 bytes in Unknown on line 0
At a guess, perhaps to due to the post_max_size variable type? Although
6144M is perhaps an excessive post size maximum, a comment in the
php.ini file warning of the maximum limit would be helpful.
Reproduce code:
---------------
Can be reproduced with the index.php page of phpMyAdmin 2.10.0.2 and
above
Expected result:
----------------
Failed login when post_max_size >= 6144M
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=45328&edit=1