cvs: phpdoc-ro /reference/imap reference.xml

From: Date: Mon, 03 Dec 2007 13:37:12 +0000
Subject: cvs: phpdoc-ro /reference/imap reference.xml
Groups: php.doc.ro 
Request: Send a blank email to doc-ro+get-319@lists.php.net to get a copy of this message
simionea Mon Dec 3 13:37:12 2007 UTC Modified files: /phpdoc-ro/reference/imap reference.xml Log: Updated the file.

http://cvs.php.net/viewvc.cgi/phpdoc-ro/reference/imap/reference.xml?r1=1.5&r2=1.6&diff_format=u Index: phpdoc-ro/reference/imap/reference.xml diff -u phpdoc-ro/reference/imap/reference.xml:1.5 phpdoc-ro/reference/imap/reference.xml:1.6 --- phpdoc-ro/reference/imap/reference.xml:1.5 Tue Sep 18 13:51:38 2007 +++ phpdoc-ro/reference/imap/reference.xml Mon Dec 3 13:37:12 2007 @@ -1,93 +1,152 @@ -<?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.5 $ --> -<!-- EN-Revision: 1.0 Maintainer: adiju Status: outdated --> +<?xml version="1.0" encoding="utf-8"?> +<!-- $Revision: 1.6 $ --> +<!-- EN-Revision: 1.19 Maintainer: simionea Status: translated --> +<!-- CREDITS: adiju --> +<!-- Purpose: remote.mail --> +<!-- Membership: bundled, external --> + <reference xml:id='ref.imap' xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> - <title>IMAP, POP3 ºi NNTP - funcþii</title> + <title>FuncÅ£ii IMAP, POP3 şi NNTP</title> <titleabbrev>IMAP</titleabbrev> <partintro> - <simpara> - Pentru ca aceste funcþii sã poatã fi folosite, trebuie sã compilaþi - PHP cu directiva <option role="configure">--with-imap</option>. - Este nevoie sã fie instalatã biblioteca c-client. Descãrcaþi ultima - versiune de la <link xlink:href="&url.imap;">&url.imap;</link> ºi compilaþi-o. - Apoi copiaþi fiºierul <filename>c-client/c-client.a</filename> în - <filename>/usr/local/lib/libc-client.a</filename> - ºi copiaþi <filename>c-client/rfc822.h</filename>, - <filename>mail.h</filename> ºi <filename>linkage.h</filename> în - <filename>/usr/local/include</filename> sau în alt director din calea - cãtre fiºiere incluse. - </simpara> - <simpara> - De notat cã aceste funcþii, in ciuda numelor pe care le au, nu sunt - limitate doar la protocolul <acronym>IMAP</acronym>. Biblioteca c-client - folositã de ele suportã, de asemenea, metode pentru acces - <acronym>NNTP</acronym>, - <acronym>POP3</acronym> ºi la o cãsuþã poºtalã localã. - </simpara> - <para> - Acest document nu îºi propune sã intre în detalii pentru toate subiectele - atinse de aceste funcþii. Mai multe informaþii puteþi citi în - documentaþia surselor bibliotecii c-client - (<filename>docs/internal.txt</filename>) precum ºi în urmãtoarele documente RFC: - <itemizedlist> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc2821.html">RFC2821</link>: Simple Mail - Transfer Protocol (SMTP). - </simpara> - </listitem> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc2822.html">RFC2822</link>: Standard for - ARPA internet text messages. - </simpara> - </listitem> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc2060.html">RFC2060</link>: Internet - Message Access Protocol (IMAP) Version 4rev1. - </simpara> - </listitem> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc1939.html">RFC1939</link>: Post - Office Protocol Version 3 (POP3). - </simpara> - </listitem> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc977.html">RFC977</link>: Network News - Transfer Protocol (NNTP). - </simpara> - </listitem> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc2076.html">RFC2076</link>: Common - Internet Message Headers. - </simpara> - </listitem> - <listitem> - <simpara> - <link xlink:href="&url.rfc;rfc2045.html">RFC2045</link>, <link - xlink:href="&url.rfc;rfc2046.html">RFC2046</link>, <link - xlink:href="&url.rfc;rfc2047.html">RFC2047</link>, <link - xlink:href="&url.rfc;rfc2048.html">RFC2048</link> ºi <link - xlink:href="&url.rfc;rfc2049.html">RFC2049</link>: Multipurpose - Internet Mail Extensions (MIME). - </simpara> - </listitem> - </itemizedlist> - O viziune mai detaliatã puteþi gãsi ºi în cãrþile - <link xlink:href="&url.email.book;">Programming Internet Email</link> - de David Wood ºi <link xlink:href="&url.imap.book;">Managing + <section xml:id="imap.intro"> + &reftitle.intro; + <para> + Aceste funÅ£ii vă permit să lucraÅ£i cu protocolul <acronym>IMAP</acronym>, + precum şi cu <acronym>NNTP</acronym>, <acronym>POP3</acronym> şi oferă + metode de acces la cutia poştală locală. + </para> + <para> + Însă vă avertizăm că unele funcÅ£ii IMAP nu vor funcÅ£iona corect cu + protocolul POP. + </para> + </section> + + <section xml:id="imap.requirements"> + &reftitle.required; + <para> + Această extensie necesită instalarea bibliotecii c-client. + ObÅ£ineÅ£i ultima versiune de la + <link xlink:href="&url.imap;">&url.imap;</link> + şi compilaÅ£i-o. + </para> + <para> + Este important să nu copiaÅ£i fişierele-sursă IMAP direct în directorul de + includeri de sistem, deoarece pot apărea conflicte. În loc, creaÅ£i un nou + director în interiorul directorului de includeri de sistem, cum ar fi de + exemplu <filename>/usr/local/imap-2000b/</filename> (amplasarea şi + denumirea depind de setările dumneavoastră şi de versiunea IMAP), şi în + interiorul acestui nou director creaÅ£i directoare suplimentare denumite + <filename>lib/</filename> şi <filename>include/</filename>. Din directorul + <filename>c-client</filename> din arborele cu sursele IMAP copiaÅ£i toate + fişierele <filename>*.h</filename> în <filename>include/</filename> şi + toate fişierele <filename>*.c</filename> în <filename>lib/</filename>. + Suplimentar, când aÅ£i compilat IMAP, a fost creat un fişier cu denumirea + <filename>c-client.a</filename>. De asemenea puneÅ£i-l în directorul + <filename>lib/</filename>, dar redenumiÅ£i-l în + <filename>libc-client.a</filename>. + </para> + <note> + <para> + Pentru a asambla biblioteca c-client cu susÅ£inerea SSL şi/sau Kerberos + citiÅ£i documentaÅ£ia furnizată cu pachetul. + </para> + </note> + <note> + <simpara> + În Mandrake Linux, biblioteca IMAP (<filename>libc-client.a</filename>) + este compilată fără susÅ£inerea Kerberos. O versiune separată cu SSL + (<filename>client-PHP4.a</filename>) este instalată. Biblioteca trebuie + să fie recompilată pentru a adăuga susÅ£inerea Kerberos. + </simpara> + </note> + </section> + + &reference.imap.configure; + + <section xml:id="imap.configuration"> + &reftitle.runtime; + &no.config; + </section> + + <section xml:id="imap.resources"> + &reftitle.resources; + <para> + </para> + </section> + + &reference.imap.constants; + + <section xml:id="imap.seealso"> + &reftitle.seealso; + <para> + Acest document nu poate cuprinde toate amănuntele subiectelor atinse de + funcÅ£iile date. InformaÅ£ii suplimentare sunt oferite de documentaÅ£ia + codului-sursă al bibliotecii c-client + (<filename>docs/internal.txt</filename>) şi de utmătoarele documente RFC: + <itemizedlist> + <listitem> + <simpara> + <link xlink:href="&url.rfc;2821">RFC2821</link>: Simple Mail + Transfer Protocol (SMTP). + </simpara> + </listitem> + <listitem> + <simpara> + <link xlink:href="&url.rfc;2822">RFC2822</link>: Standard for + ARPA internet text messages. + </simpara> + </listitem> + <listitem> + <simpara> + <link xlink:href="&url.rfc;2060">RFC2060</link>: Internet + Message Access Protocol (IMAP) Version 4rev1. + </simpara> + </listitem> + <listitem> + <simpara> + <link xlink:href="&url.rfc;1939">RFC1939</link>: Post + Office Protocol Version 3 (POP3). + </simpara> + </listitem> + <listitem> + <simpara> + <link xlink:href="&url.rfc;977">RFC977</link>: Network News + Transfer Protocol (NNTP). + </simpara> + </listitem> + <listitem> + <simpara> + <link xlink:href="&url.rfc;2076">RFC2076</link>: Common + Internet Message Headers. + </simpara> + </listitem> + <listitem> + <simpara> + <link xlink:href="&url.rfc;2045">RFC2045</link> , <link + xlink:href="&url.rfc;2046">RFC2046</link> , <link + xlink:href="&url.rfc;2047">RFC2047</link> , <link + xlink:href="&url.rfc;2048">RFC2048</link> &amp; <link + xlink:href="&url.rfc;2049">RFC2049</link>: Multipurpose + Internet Mail Extensions (MIME). + </simpara> + </listitem> + </itemizedlist> + O privire generală de detaliu este disponibilă în cărÅ£ile + <link xlink:href="&url.email.book;">Programming Internet Email</link> + de David Wood şi <link xlink:href="&url.imap.book;">Managing IMAP</link> de Dianna Mullet &amp; Kevin Mullet. - </para> + </para> + </section> </partintro> &reference.imap.functions; </reference> + +<!-- Translated by Simion Onea. --> + <!-- Keep this comment at the end of the file Local variables: mode: sgml @@ -108,4 +167,3 @@ vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> -
« previous php.doc.ro (#319) next »