Re: Callbacks

From: Date: Mon, 23 Jun 2003 08:45:39 +0000
Subject: Re: Callbacks
References: 1 2 3  Groups: php.doc 
Request: Send a blank email to phpdoc+get-969354798@lists.php.net to get a copy of this message
Davey wrote:
I am fine with the callback type, and the "handler" name to use for callback paramater names. Goba
It seems that "callback" and "handler" are well recieved, would you like for me to go through and change all functions which use callbacks to have this?
IMHO "handler" only makes sense where one can't come up with another more descriptive parameter name for the callback function/method passed ... take the usort() function for an example, its current prototype is void usort ( array array, callback cmp_function) if you changed it to void usort ( array array, callback handler) you lose a *lot* of information on what the function does ... -- Hartmut Holzgraefe <hartmut@php.net>

« previous php.doc (#969354798) next »