Re: Callbacks
| From: | Davey | Date: | Wed, 25 Jun 2003 02:29:25 +0000 |
| Subject: | Re: Callbacks | ||
| References: | 1 2 3 4 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969354843@lists.php.net to get a copy of this message | ||
Hartmut Holzgraefe wrote:
Davey wrote:I will keep that in mind. I'll try to use descriptive names where possible, and I won't remove any names unless they are currently "callback". - DaveyIMHO "handler" only makes sense where one can't come up with another more descriptive parameter name for the callback function/method passed ... take the usort() function for an example, its current prototype is void usort ( array array, callback cmp_function) if you changed it to void usort ( array array, callback handler) you lose a *lot* of information on what the function does ...I am fine with the callback type, and the "handler" name to use for callback paramater names. GobaIt seems that "callback" and "handler" are well recieved, would you like for me to go through and change all functions which use callbacks to have this?