#29708 [Bgs]: Cannot get PHP-CGI.exe to run properly for PHP 5
| From: | gabe at horizondatacom dot com | Date: | Tue, 17 Aug 2004 13:05:37 +0000 |
| Subject: | #29708 [Bgs]: Cannot get PHP-CGI.exe to run properly for PHP 5 | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969363259@lists.php.net to get a copy of this message | ||
ID: 29708
User updated by: gabe at horizondatacom dot com
Reported By: gabe at horizondatacom dot com
Status: Bogus
Bug Type: Documentation problem
Operating System: Windows 2003
PHP Version: 5.0.1
New Comment:
Correct, that's why I opened the bug as a documentation problem. I
followed the directions in the PHP distribution and it doesn't work.
I've got several other users that are having the exact same problem as
well, even after following the installation instructions.
Currently, all I can get to work is the ISAPI module and I'm trying to
convert over to CGI as the installation instructions recomend for
production sites. Is this still a canidate for a bug?
Previous Comments:
------------------------------------------------------------------------
[2004-08-17 08:02:37] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself. For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system
is not the
appropriate forum for asking support questions.
Thank you for your interest in PHP.
.
------------------------------------------------------------------------
[2004-08-16 18:09:04] gabe at horizondatacom dot com
PHP ISAPI Information
=================================================
System Windows NT BETABOX 5.2 build 3790
Build Date Aug 12 2004 23:30:01
Configure Command cscript /nologo configure.js "--with-gd=shared"
"--enable-snapshot-build"
Server API ISAPI
Virtual Directory Support enabled
Configuration File (php.ini) Path C:\WINDOWS\php.ini
PHP API 20031224
PHP Extension 20040412
Zend Extension 220040412
Debug Build no
Thread Safety enabled
IPv6 Support enabled
Registered PHP Streams php, file, http, ftp, compress.zlib
Registered Stream Socket Transports tcp, udp
------------------------------------------------------------------------
[2004-08-16 18:06:38] gabe at horizondatacom dot com
Description:
------------
I'm having a problem to get PHP 5.0.1 to work for IIS6 in Windows 2003.
I've been successful in getting ISAPI to run but I need the stability
of CGI for my projects. I've followed the instructions to setup ISAPI
with good luck here:
IIS6 ISAPI SETUP
http://www.visualwin.com/PHP-ISAPI/
IIS6 CGI SETUP
http://www.visualwin.com/PHP/
But I've also tried to follow the instructions on the same site for
setting up CGI but I keep getting an error. Here is the error message
I get after trying to setup CGI.
******** IIS ERROR MESSAGE ******************
You are not authorized to view this page
You do not have permission to view this directory or page using the
credentials that you supplied.
Please try the following:
* Contact the Web site administrator if you believe you should be
able to view this directory or page.
* Click the Refresh button to try again with different
credentials.
HTTP Error 403 - Forbidden: Access is denied.
Internet Information Services (IIS)
******** IIS ERROR MESSAGE ******************
I have double checked all permissions on the executables and the
scripts as well. All have access and permissions for the web service
to read and execute. I've also tried to see if IIS6 was not allowing
it because of the web service permissions. So I allowed ALL services
access and I'm still having the same result. Is there somthing that
I'm missing from the installation documentation?
Also, to eliminate the fact the IIS was doing this to every file, I
renamed my phpinfo() file to a .HTML and I was able to view the source
code. So it is definitly not somthing wrong with folder permissions.
I'm using PHP-CGI.exe for windows environments too.
Reproduce code:
---------------
<?php
phpinfo();
?>
Expected result:
----------------
I should expect to see the PHP info page, but instead I see an IIS
permission denied error.
Actual result:
--------------
******** IIS ERROR MESSAGE ******************
You are not authorized to view this page
You do not have permission to view this directory or page using the
credentials that you supplied.
Please try the following:
* Contact the Web site administrator if you believe you should be
able to view this directory or page.
* Click the Refresh button to try again with different
credentials.
HTTP Error 403 - Forbidden: Access is denied.
Internet Information Services (IIS)
******** IIS ERROR MESSAGE ******************
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=29708&edit=1