Re: #29708 [Opn]: Cannot get PHP-CGI.exe to run properly for PHP 5
| From: | (PHPDiscuss - PHP Newsgroups and mailing lists) | Date: | Mon, 20 Sep 2004 13:52:00 +0000 |
| Subject: | Re: #29708 [Opn]: Cannot get PHP-CGI.exe to run properly for PHP 5 | ||
| References: | 1 2 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969364199@lists.php.net to get a copy of this message | ||
it is the rights of the identity of the Application Pool. I switched it to
"local system" and it worked. The dumb part is that it's not a secure
thing...
there are some policies that must be set for the Network services, but i
couldn't get it right
Gabe At Horizondatacom Dot Com wrote:
> ID: 29708
> User updated by: gabe at horizondatacom dot com
> Reported By: gabe at horizondatacom dot com
> Status: Open
> Bug Type: Documentation problem
> Operating System: Windows 2003
> PHP Version: 5.0.1
> New Comment:
> PHP ISAPI Information
> =================================================
> System Windows NT BETABOX 5.2 build 3790
> Build Date Aug 12 2004 23:30:01
> Configure Command cscript /nologo configure.js "--with-gd=shared"
> "--enable-snapshot-build"
> Server API ISAPI
> Virtual Directory Support enabled
> Configuration File (php.ini) Path C:WINDOWSphp.ini
> PHP API 20031224
> PHP Extension 20040412
> Zend Extension 220040412
> Debug Build no
> Thread Safety enabled
> IPv6 Support enabled
> Registered PHP Streams php, file, http, ftp, compress.zlib
> Registered Stream Socket Transports tcp, udp
> Previous Comments:
> ------------------------------------------------------------------------
> [2004-08-16 18:06:38] gabe at horizondatacom dot com
> Description:
> ------------
> I'm having a problem to get PHP 5.0.1 to work for IIS6 in Windows 2003.
> I've been successful in getting ISAPI to run but I need the stability
> of CGI for my projects. I've followed the instructions to setup ISAPI
> with good luck here:
> IIS6 ISAPI SETUP
> http://www.visualwin.com/PHP-ISAPI/
> IIS6 CGI SETUP
> http://www.visualwin.com/PHP/
> But I've also tried to follow the instructions on the same site for
> setting up CGI but I keep getting an error. Here is the error message
> I get after trying to setup CGI.
> ******** IIS ERROR MESSAGE ******************
> You are not authorized to view this page
> You do not have permission to view this directory or page using the
> credentials that you supplied.
> Please try the following:
> * Contact the Web site administrator if you believe you should be
> able to view this directory or page.
> * Click the Refresh button to try again with different
> credentials.
> HTTP Error 403 - Forbidden: Access is denied.
> Internet Information Services (IIS)
> ******** IIS ERROR MESSAGE ******************
> I have double checked all permissions on the executables and the
> scripts as well. All have access and permissions for the web service
> to read and execute. I've also tried to see if IIS6 was not allowing
> it because of the web service permissions. So I allowed ALL services
> access and I'm still having the same result. Is there somthing that
> I'm missing from the installation documentation?
> Also, to eliminate the fact the IIS was doing this to every file, I
> renamed my phpinfo() file to a .HTML and I was able to view the source
> code. So it is definitly not somthing wrong with folder permissions.
> I'm using PHP-CGI.exe for windows environments too.
> Reproduce code:
> ---------------
> <?php
> phpinfo();
> ?>
> Expected result:
> ----------------
> I should expect to see the PHP info page, but instead I see an IIS
> permission denied error.
> Actual result:
> --------------
> ******** IIS ERROR MESSAGE ******************
> You are not authorized to view this page
> You do not have permission to view this directory or page using the
> credentials that you supplied.
> Please try the following:
> * Contact the Web site administrator if you believe you should be
> able to view this directory or page.
> * Click the Refresh button to try again with different
> credentials.
> HTTP Error 403 - Forbidden: Access is denied.
> Internet Information Services (IIS)
> ******** IIS ERROR MESSAGE ******************
> ------------------------------------------------------------------------