Re: cvs: phpdoc /en/reference/errorfunc/functions restore-error-handler.xml

From: Date: Mon, 04 Apr 2005 21:21:34 +0000
Subject: Re: cvs: phpdoc /en/reference/errorfunc/functions restore-error-handler.xml
References: 1 2 3  Groups: php.doc 
Request: Send a blank email to phpdoc+get-969367421@lists.php.net to get a copy of this message
+// redefine the user error constants - PHP 4 only +define("FATAL", E_USER_ERROR); +define("ERROR", E_USER_WARNING); +define("WARNING", E_USER_NOTICE);
Is this from a different part of the manual? Is it supposed to be a good idea to rename WARNING to ERROR and NOTICE to WARNING? It is becoming a support nightmare then isn't it?
I just copied it from the set_error_handler docs and changed the code so it demonstrated the revert to previous handler function.
Yes, this was my suspicion... So I would like to hear others' opinions about the above confusing people (or not?). Goba

« previous php.doc (#969367421) next »