Re: cvs: phpdoc /en/reference/errorfunc/functions

From: Date: Tue, 05 Apr 2005 07:21:10 +0000
Subject: Re: cvs: phpdoc /en/reference/errorfunc/functions
References: 1 2 3 4 5  Groups: php.doc 
Request: Send a blank email to phpdoc+get-969367436@lists.php.net to get a copy of this message
Yeah, I agree with the changes. It would make it much less confusing when you actually see the error output! Mehdi Achour wrote:
Gabor Hojtsy wrote:
+// redefine the user error constants - PHP 4 only +define("FATAL", E_USER_ERROR); +define("ERROR", E_USER_WARNING); +define("WARNING", E_USER_NOTICE);
         
Is this from a different part of the manual? Is it supposed to be a good idea to rename WARNING to ERROR and NOTICE to WARNING? It is becoming a support nightmare then isn't it?
       
I just copied it from the set_error_handler docs and changed the code so it demonstrated the revert to previous handler function.
     
Yes, this was my suspicion... So I would like to hear others' opinions about the above confusing people (or not?).
+1 for change it, and also to prefix the constants with something. (APP_ERROR, .. ) Mehdi


« previous php.doc (#969367436) next »