#42339 [Opn]: Can't Build a CLI *only* must have APXS enabled
| From: | codeslinger at compsalot dot com | Date: | Sat, 18 Aug 2007 17:46:22 +0000 |
| Subject: | #42339 [Opn]: Can't Build a CLI *only* must have APXS enabled | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969377694@lists.php.net to get a copy of this message | ||
ID: 42339
User updated by: codeslinger at compsalot dot com
Reported By: codeslinger at compsalot dot com
Status: Open
-Bug Type: Compile Failure
+Bug Type: Documentation problem
Operating System: SimplyMEPIS Linux 6.5
PHP Version: 5.2.3
New Comment:
this is actually a documentation problem.
the correct command should be
'./configure' --enable-cli --disable-cgi --disable-apxs
Previous Comments:
------------------------------------------------------------------------
[2007-08-18 17:36:23] codeslinger at compsalot dot com
Description:
------------
There are many options for PHP, such as ncurses, which are not
compatible with phpN-mod.so
But when trying to build a CLI only config, it fails with an error
message that APXS is not enabled.
Reproduce code:
---------------
I tried many variants, here is the simplest:
'./configure' --enable-cli --disable-cgi --without-apxs2
--without-apxs
Expected result:
----------------
Expected: No errors
Note: the following command *does* work
'./configure' --enable-cli --disable-cgi
'--with-apxs2=/usr/bin/apxs2'
Actual result:
--------------
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...
Sorry, I was not able to successfully run APXS. Possible reasons:
1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /usr/local/src/php-5.2.3/no follows
./configure: line 4396: /usr/local/src/php-5.2.3/no: No such file or
directory
configure: error: Aborting
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=42339&edit=1