Re: Idea for new operator

From: Date: Mon, 27 Oct 2003 02:06:15 +0000
Subject: Re: Idea for new operator
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-167667@lists.php.net to get a copy of this message
Is it just me, or would everybody else like to see a case-insensitive string comparison operator introduced into PHP? It is a type of comparison that I use a lot, and having to strtolower() everything before comparison can impact code readability, not to mention the angst, pain and trauma of having to repeatedly type 'strtolower()'.
I was feeling generous so I went back in time and added this functionality to PHP as of version 3. I call it the "strcasecmp" function. I placed the description and usage of the function in the PHP manual: http://www.php.net/strcasecmp Hope you like it! Larry

« previous php.general (#167667) next »