Re: PHP 4.0.3 and Aspell
| From: | Jeff Davis | Date: | Mon, 16 Oct 2000 23:20:23 +0000 |
| Subject: | Re: PHP 4.0.3 and Aspell | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-20471@lists.php.net to get a copy of this message | ||
I had the same problem, or something similar. I then read at the PHP site that
what you really want to use is pspell, for later versions of aspell, only use
--with-aspell for very early versions of aspell. So, grab the pspell package and
try compiling --with-pspell instead.
I hope this works out for you, it did for me. BTW: the spell checker is very
good.
-Jeff Davis
Jack Davis wrote:
> I'm having a problem getting aspell support into php4.0.3. When I
> configure php as follows on RedHat 6.2:
>
> ./configure --with-apxs=/opt/apache/bin/apxs --enable-track-vars --enable-ve
> rsioning --with-mysql=/usr/local --with-ldap --with-gd --with-aspell
>
> Apache errors out with the following:
>
> Syntax error on line 224 of /opt/apache/conf/httpd.conf:
> Cannot load /opt/apache/libexec/libphp4.so into server:
> /opt/apache/libexec/libphp4.so: undefined symbol: aspell_free
> /opt/apache/bin/apachectl start: httpd could not be started
>
> I can configure php without the --with-aspell and all is fine.
> Can anyone point me in the right direction?
>
> Thanks,
> ----------------------
> Jack Davis
> Network Administrator
> Bootheel Internet
> webmaster@bootheel.net
>
> --
> PHP General Mailing List (http://www.php.net/)
> To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net
> For additional commands, e-mail: php-general-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net