Re: Memory exhausted message wrong
| From: | Marek Kilimajer | Date: | Fri, 18 Mar 2005 15:10:24 +0000 |
| Subject: | Re: Memory exhausted message wrong | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-211048@lists.php.net to get a copy of this message | ||
Andrew Hill wrote:
Hi all, I'm trying to run phpDocumentor 1.3.0RC3 under PHP 4.3.10, and I get the following error: Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 3668 bytes) in /usr/local/lib/php/PhpDocumentor/phpDocumentor/phpDocumentorTWordParser. inc on line 236 The problem is that in my php.ini file, I have the line: memory_limit = 8M So, why is PHP reporting that the allowed memory size is 256M? The phpinfo() function correctly reports that memory_limit is set to 8M. With this problem, I can't run phpDocumentor, as it doesn't matter how large I set memory_limit in php.ini, it always crashes with the same error. TIA,Are you running phpini() from command line? cli-php might be using another php.ini