Problems after compiling PHP4.02
| From: | Steven Holloway | Date: | Fri, 03 Nov 2000 04:56:36 +0000 |
| Subject: | Problems after compiling PHP4.02 | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-23518@lists.php.net to get a copy of this message | ||
Hi all,
Spent some time trying to update PHP4
and I also recompiled apache to enable DSO
all fine
using RedHat 6.2 (seem to have a lot of problems with RH lately)
apache_1.3.14
PHP 4.02
i have compiled PHP4 as an Apache DSO without errors
./configure -enable-mysql=/usr/local/mysql -with-apxs=/usr/local/apache_1.3.
14/bin/apxs
make returned no errors
make install returned no errors
then I modified httpd.conf to parse .php .phtml .php3 files
then started apache and got the following
<error>
Syntax error on line 207 of /usr/local/apache_1.3.14/conf/httpd.conf:
Cannot load /usr/local/apache_1.3.14/libexec/libphp4.so into server:
/usr/local/
apache_1.3.14/libexec/libphp4.so: undefined symbol: uncompress
bin/apachectl start: httpd could not be started
</error>
so it seems the libphp4.so did not compile properly
even though the mak and make install of PHP returned no errors
am looking ionto the problem but it would br great
if anyone has seen this before and knows a work round
Cheers
Steven
*******************************
Steven Michael Holloway
Web Programmer
Port Douglas Internet Services
Cairns Australia
steven@pdis.com.au
*******************************