Re: Problems after compiling PHP4.02

From: Date: Fri, 03 Nov 2000 13:25:36 +0000
Subject: Re: Problems after compiling PHP4.02
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-23567@lists.php.net to get a copy of this message
Hi Steven, I have the exact same problem for php-4.0.3 and apache_1.3.12 on slack. I tried for a whole night and could not find a work around, I then compiled php as a static module with the exact same configure line and setup and everything is fine. Miguel Feitosa './configure' '--with-mysql=/usr/local/mysql' '--with-pdflib=/usr/local/pdflib/include' '--enable-short-tags' '--enable-url-fopen-wrapper' '--enable-calendar' '--enable-ftp' '--with-gd' '--with-pcre-regex' '--enable-xml' '--with-apache=/usr/local/apache_1.3.12' '--enable-dbase' '--with-imap' '-with-jpeg=/usr/local/jpeg-6b/' Steven Holloway wrote: > > Hi all, > > Spent some time trying to update PHP4 > > and I also recompiled apache to enable DSO > > all fine > > using RedHat 6.2 (seem to have a lot of problems with RH lately) > apache_1.3.14 > PHP 4.02 > i have compiled PHP4 as an Apache DSO without errors > > ./configure -enable-mysql=/usr/local/mysql -with-apxs=/usr/local/apache_1.3. > 14/bin/apxs > make returned no errors > make install returned no errors > > then I modified httpd.conf to parse .php .phtml .php3 files > > then started apache and got the following > > <error> > Syntax error on line 207 of /usr/local/apache_1.3.14/conf/httpd.conf: > Cannot load /usr/local/apache_1.3.14/libexec/libphp4.so into server: > /usr/local/ > apache_1.3.14/libexec/libphp4.so: undefined symbol: uncompress > bin/apachectl start: httpd could not be started > </error> > > so it seems the libphp4.so did not compile properly > even though the mak and make install of PHP returned no errors > am looking ionto the problem but it would br great > if anyone has seen this before and knows a work round > > Cheers > Steven > > ******************************* > Steven Michael Holloway > Web Programmer > Port Douglas Internet Services > Cairns Australia > steven@pdis.com.au > ******************************* > > -- > PHP General Mailing List (http://www.php.net/) > To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net > For additional commands, e-mail: php-general-help@lists.php.net > To contact the list administrators, e-mail: php-list-admin@lists.php.net

« previous php.general (#23567) next »