Re: "Module not open" apache error
| From: | Richard Lynch | Date: | Mon, 04 Dec 2000 14:50:28 +0000 |
| Subject: | Re: "Module not open" apache error | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-28587@lists.php.net to get a copy of this message | ||
Wild guesses:
Is the module readable/executable?
Try not using suexec and/or mod_ssl and see if you can find an interaction
issue...
Check for "Module not open" on http://bugs.php.net and
in the Mailing List
archives...
----- Original Message -----
From: Jeff Davis <jdavis@wasabimg.com>
Newsgroups: php.general
Sent: Monday, December 04, 2000 2:08 AM
Subject: [PHP] "Module not open" apache error
> I have set up PHP many times. I just recently set up apache 1.3.14 with
> mod_ssl, and suexec and then tried to as PHP in afterward (as usual,
> I compiled Apache with "SHARED_CORE" and "so").
>
> when I try to start it:
> Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp4.so into server: shared
> object not open
>
> here is line 207:
> LoadModule php4_module libexec/libphp4.so
>
> the file exists (because when I rename it it gives me a "not found"
> error).
>
> Can someone help out? I have never had a problem loading a PHP module
> before. Perhaps it is bad? perhaps apache wasn't properly set up with
> dso support? I have tried everything I could think of, and I looked for
> documentation at the site.
>
> Thanks!
> Jeff Davis
>
>
> --
> PHP General Mailing List (http://www.php.net/)
> To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net
> For additional commands, e-mail: php-general-help@lists.php.net
> To contact the list administrators, e-mail: php-list-admin@lists.php.net
>