Apache 1.3.14 probs w/php4.03pl1

From: Date: Mon, 11 Dec 2000 17:50:54 +0000
Subject: Apache 1.3.14 probs w/php4.03pl1
Groups: php.general 
Request: Send a blank email to php-general+get-29717@lists.php.net to get a copy of this message
I'm brand new to this list and am not sure if this is an appropriate question, or there is a better place, but here goes... I'm trying to add php-4.0.3pl1 to a new apache server (Apache/1.3.14 mod_perl/1.21 mod_ssl/2.7.1-1.3.14 openssl/0.9.6) My os is RedHat 6.2 I configure with: ./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs the make and make install appear to work flawlessly, without any complaints. However when I restart apache, I always get the following: [root@computer-essence] - php-4.0.3pl1# /etc/rc.d/init.d/httpd restart Shutting down http: [FAILED] Starting httpd: Syntax error on line 210 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol: uncompress [FAILED] I have checked the configure file, and discovered that at about line 14100 the following entry exists for compress, but no entries what so ever exist for uncompress. char compress(); int main() { compress() ; return 0; } EOF I was thinking of copying that and change compress to uncompress in the copy, but I have no programing experience, and was hoping someone might have a better solution... Thanks for any help or comments. Gary

« previous php.general (#29717) next »