Re: Array Symbol Suggestion
| From: | Per Jessen | Date: | Thu, 13 Jan 2011 07:01:04 +0000 |
| Subject: | Re: Array Symbol Suggestion | ||
| References: | 1 2 3 4 5 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-310723@lists.php.net to get a copy of this message | ||
Ashley Sheridan wrote:
> On Wed, 2011-01-12 at 12:23 -0800, sono-io@fannullone.us wrote:
>
>> Thanks for all the responses to my suggestion. I realize this would
>> be a major change, so that's why I also mentioned it as an addition
>> to the language.
>>
>> I'm sure it's just what you're used to, but still being new to all
>> this, it just makes sense (to me anyway) to have different symbols
>> for different variable types: $scalar @array
>> #hash
>>
>> Since the @ sign is already reserved, maybe there's another symbol
>> that would work better? I don't know. These are just ideas that I
>> came up with while reading and I thought I'd throw it out there to
>> see what others thought.
>>
>> I like the idea of a naming convention, so that's what I'll do in my
>> scripts. I also appreciate the heads up on is_string(), is_array(),
>> and var_dump().
>>
>> Thanks again,
>> Marc
>
>
> If you check out the manual pages for those functions as well, you'll
> see other related functions. I must say, of any language I've used,
> the php.net documentation is by far the best, giving plenty of
> information and user comments too. It's a resource I still can't do
> without, and I reckon even the old hands on this list would say the
> same.
Yes, I wouldn't want to be without my local php.net mirror. Other
languages that can easily match the quality of the documentation -
assembler, C and C++, to name a few.
--
Per Jessen, Zürich (7.9°C)