Re: Apache error after setting path for mysql=

From: Date: Thu, 11 Jan 2001 04:24:57 +0000
Subject: Re: Apache error after setting path for mysql=
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-33889@lists.php.net to get a copy of this message
Hello Shane, (SR == "Shane Reid") nebula@igg.net writes: SR> I reconfigured php with ./configure SR> --with-mysql=/usr/local/etc/mysql SR> --with-apxs=/usr/local/etc/apache/bin/apxs and apache will no SR> longer start. I removed the path from the mysql to get the SR> webserver back up but my question was why would it not be able to SR> find libmysqlclient.so.10 (error down below). The file is located SR> at /usr/local/etc/mysql/lib/mysql/libmysqlclient.so.10 ... any SR> reason its not picking up the fact that its there when I pointed SR> it to the directory I told mysql to install to? I don't know if this is your problem for sure, but here goes.. configure says: for i in lib lib/mysql; do str="$MYSQL_DIR/$i/libmysqlclient.*" for j in echo $str; do if test -r $j; then MYSQL_LIB_DIR="$MYSQL_DIR/$i" break 2 fi done done if test -z "$MYSQL_LIB_DIR"; then { echo "configure: error: Cannot find mysqlclient library under $MYSQL_DIR" 1>&2; exit 1; } fi So it's checking /usr/local/etc/mysql/lib/libmysqlclient.* and /usr/local/etc/mysql/lib/mysql/libmysqlclient.* And it didn't spit out: "configure: error: Cannot find mysqlclient library under /usr/local/etc/mysql" Right? Then it obviously found it, which prompted you to start Apache. SR> Cannot load /usr/local/etc/apache/libexec/libphp4.so into server: SR> Shared object "libmysqlclient.so.10" not found Try sticking the path to that library (/usr/local/etc/mysql/lib/mysql) into ld.so.conf and run ldconfig once as root. Then build php with mysql support again and start apache. I find myself saying this a lot <g>, but see if that fixes it. SR> -Shane Maybe someone else will pipe up here soon with a definite answer if that doesn't fix your problem. -Brian -- The end of the day is near when small men make long shadows.

« previous php.general (#33889) next »