Help needed tsrm_error
| From: | Tony Brown | Date: | Thu, 01 Feb 2001 16:16:26 +0000 |
| Subject: | Help needed tsrm_error | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-37650@lists.php.net to get a copy of this message | ||
Hello all,
I have an issue that I can not seem to resolve. Scenario:
Solaris 2.7
Netscape Enterprise Server 4.1
PHP 4.0.4
Oracle 8i
Configured as:
--enable-debug
--enable-pic
--enable-inline-optimization
--with-regex=system
--with-gettext=/usr/bin
--enable-safe-mode
--enable-sysvmem
--enable-sysvshm
--enable-track-vars
--enable-ftp
--with-xml
--with-nsapi=/usr/netscape/server4
--with-oracle=/vol01/app/oracle/product/8.1.6
--enable-libgcc
The problem occurs when I issue ./start to netscape, I get the following
error:
conf_init: Error running init function load-modules: dlopen of
/usr/netscape/server4/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal:
relocation error: file /usr/netscape/server4/bin/libphp4.so: symbol
tsrm_error referenced symbol not found)
I have tried configuring --with-tsrm-pthreads and I did not get an error
when I issue ./start for netscape, however the page with xml code shows up
blank in my browser after this happens.
I have played around with LD_LIBRARY_PATH trying to find where tsrm_error
resides (multiple net searches also) and can not seem to find any useful
information.
I researched a similar problem and the person that resolved it says that he
had to 'add a patch for ZTS and use the --enable-experimental-zts flag'. I
tried the --enable-experimental-zts flag with no success. I searched the
net for ZTS and could not find a download.
Can anyone help? What is tsrm?
Thanks in advance,
Tony