starting Apache: unable to find OpenLDAP library path
| From: | Charlie Hileman | Date: | Thu, 21 Jun 2001 20:02:44 +0000 |
| Subject: | starting Apache: unable to find OpenLDAP library path | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-54797@lists.php.net to get a copy of this message | ||
Hello,
I have a problem when running Apache (1.3.19) using PHP (4.0.4) and
OpenLDAP . The following error occurs when starting up Apache (PHP run
internally as a shared module in Apache):
> Cannot load /usr/web/server/apache/libexec/libphp4.so into server:
libldap.so.2:
> cannot open shared object file: No such file or directory
I am able to stop this error by setting LD_LIBRARY_PATH to the OpenLDAP
lib directory. So I assume the problem is related to the proper library
load path when linking either Apache or PHP.
I use the following command to configure the PHP installation:
> ./configure --with-apxs=/usr/web/server/apache/bin/apxs \
> --prefix=/usr/web/server/php \
> --with-config-file-path=/usr/web/server/php \
> --with-ldap=/usr/web/server/openldap \
> --enable-track-vars --enable-magic-quotes --enable-debugger \
> --with-mysql --enable-ftp
And I use the following command to configure the Apache installation
(with additional modifications to httpd.conf):
./configure --prefix=/usr/local/web/server/apache/ \
--enable-module=mime_magic --enable-shared=mime_magic \
--enable-module=headers --enable-shared=headers \
--enable-module=info --enable-shared=info \
--enable-module=rewrite --enable-shared=rewrite \
--enable-module=speling --enable-shared=speling \
--enable-module=cgi --enable-shared=cgi \
--enable-module=alias --enable-shared=alias \
--enable-module=auth --enable-shared=auth
When PHP links libphp4 the proper L switch appears to be used to
include the openldap library directory. I assume that PHP needs the
library path. But for some reason it is not able to find that path once
PHP is installed as a shared dynamic object for Apache.
Any ideas?
Many thanks,
Charlie Hileman (freediver@bellsouth.net).