Re: starting Apache: unable to find OpenLDAP library path

From: Date: Fri, 22 Jun 2001 00:56:32 +0000
Subject: Re: starting Apache: unable to find OpenLDAP library path
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-54827@lists.php.net to get a copy of this message
> I have a problem when running Apache (1.3.19) using PHP (4.0.4) and > OpenLDAP . The following error occurs when starting up Apache (PHP run > internally as a shared module in Apache): > > > Cannot load /usr/web/server/apache/libexec/libphp4.so into server: > libldap.so.2: > > cannot open shared object file: No such file or directory Which OS? If Linux, edit your /etc/ld.so.conf file and add the directory libldap.so.2 is in to that file, then run ldconfig. If some other OS, figure out how to change the default LD_LIBRARY_PATH for your system. We don't do all the -R's that we should in PHP, so you need to help it along a bit. -Rasmus

« previous php.general (#54827) next »