Re: CGI error

From: Date: Tue, 24 Jul 2001 20:06:11 +0000
Subject: Re: CGI error
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-59421@lists.php.net to get a copy of this message
On Tuesday 24 July 2001 20:44, Phil Spitler wrote: > There must be some sort of bug with IIS and PHP. > Everything was set up correctly and I was pointing to the correct the > correct path for the cgi .exe file. However it didn't start working for me > until checking "Check that file exists" in the "App Mappings". This fixed > the problem after HOURS of troubleshooting. I don't think there's a bug here. Ticking that box does two important things. Firstly it stops the 'the specified CGI application misbehaved by not returning a complete set of headers' error message which is often caused by php not finding the script you specified because it is not there. IIS checks whether the script file exists, and if it doesn't, it sends a 404 error rather than running php. Secondly, when it checks the file and finds that the web server does not have permission to read it, it sends authentication headers (or does all that NT authentication unpleasantness if you have it enabled) in order to attempt to get sufficient permission to read the file. Basically, this is just the way IIS works. You'd get exactly the same results with any other cgi script interpreter. Cheers -- Phil Driscoll

« previous php.general (#59421) next »