RE: [PHP] CGI error

From: Date: Tue, 24 Jul 2001 20:34:37 +0000
Subject: RE: [PHP] CGI error
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-59434@lists.php.net to get a copy of this message
I hear what you are saying. I just don't understand why if php.exe is where I was telling it and permissions were all set up correctly, why it started working after that was checked. I did nothing else but check it and if I understand what you are telling me, it should've given me a 404 error. Phil > -----Original Message----- > From: Phil Driscoll [mailto:phil@dialsolutions.co.uk] > Sent: Tuesday, July 24, 2001 4:06 PM > To: Phil Spitler; php-general@lists.php.net > Subject: Re: [PHP] CGI error > > > On Tuesday 24 July 2001 20:44, Phil Spitler wrote: > > There must be some sort of bug with IIS and PHP. > > Everything was set up correctly and I was pointing to the correct the > > correct path for the cgi .exe file. However it didn't start > working for me > > until checking "Check that file exists" in the "App Mappings". > This fixed > > the problem after HOURS of troubleshooting. > > I don't think there's a bug here. > Ticking that box does two important things. > Firstly it stops the 'the specified CGI application misbehaved by not > returning a complete set of headers' error message which is often > caused by > php not finding the script you specified because it is not there. > IIS checks > whether the script file exists, and if it doesn't, it sends a 404 error > rather than running php. > Secondly, when it checks the file and finds that the web server > does not have > permission to read it, it sends authentication headers (or does > all that NT > authentication unpleasantness if you have it enabled) in order to > attempt to > get sufficient permission to read the file. > > Basically, this is just the way IIS works. You'd get exactly the > same results > with any other cgi script interpreter. > > Cheers > -- > Phil Driscoll > > -- > PHP General Mailing List (http://www.php.net/) > To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net > For additional commands, e-mail: php-general-help@lists.php.net > To contact the list administrators, e-mail: php-list-admin@lists.php.net >

« previous php.general (#59434) next »