How would you code: $r = func() or return 0?
| From: | scott [gts] | Date: | Wed, 26 Sep 2001 20:46:15 +0000 |
| Subject: | How would you code: $r = func() or return 0? | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-68919@lists.php.net to get a copy of this message | ||
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
I thought i'd ask for your comments on how you'd code this
common perl code with PHP:
$value = some_function() or return 0;
i usually code my functions to return 0 or "" on error, but
have to use the following code to handle it... neither seem
like a good solution to me.
this way decreses the readability of the code:
if (!$value = some_function)
return 0;
and this way adds an unnecessary if() statement:
$value = some_function()
if (!$value) {
return 0;
}
-----BEGIN PGP SIGNATURE-----
Version: PGPfreeware 7.0.3 for non-commercial use <http://www.pgp.com>
iQA/AwUBO7I+l8aXTGgZdrSUEQLW3wCbBhH8w+P+EgJxvs46H9JUtx9q0iUAoKeg
pRwrJ6NH230r0EQZl3Wvc5Wl
=sUof
-----END PGP SIGNATURE-----