Re: How would you code: $r = func() or return 0?

From: Date: Wed, 26 Sep 2001 20:57:06 +0000
Subject: Re: How would you code: $r = func() or return 0?
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-68920@lists.php.net to get a copy of this message
On Wed, 26 Sep 2001, scott [gts] wrote: > > -----BEGIN PGP SIGNED MESSAGE----- > Hash: SHA1 > > I thought i'd ask for your comments on how you'd code this > common perl code with PHP: > > $value = some_function() or return 0; > > i usually code my functions to return 0 or "" on error, but > have to use the following code to handle it... neither seem > like a good solution to me. > > this way decreses the readability of the code: > if (!$value = some_function) > return 0; > > and this way adds an unnecessary if() statement: > $value = some_function() > if (!$value) { > return 0; > } The last way is how you would do it... And FYI, its an extra if statement in the Perl code too (speed wise)... -Sterling

« previous php.general (#68920) next »