Re: apache1.3.22 won't start with php4.0.6
| From: | Brian Clark | Date: | Tue, 30 Oct 2001 00:15:01 +0000 |
| Subject: | Re: apache1.3.22 won't start with php4.0.6 | ||
| References: | 1 2 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-72797@lists.php.net to get a copy of this message | ||
Hi Edward,
@ 4:25:53 PM on 10/29/2001, Edward Quick wrote:
> Absolutely nothing.
Don't take this as my assuming you're incompetent. It's just that we
need more information about your system in order to help you.
You wrote:
> I have just installed Apache 1.3.22 but when I load php4.0.6 it
> won't run
Define "load php4.0.6" exactly. Did you build PHP as a DSO
(--with-apxs) or did you build it into httpd (--with-apache)? Did you
install from an RPM?
Assuming Apache is installed in one of the usual places, and assuming
you're on a Unix or Linux system..
What happens when you run:
$
which apachectl configtest
Does it say "Syntax OK"?
What do you get when you run:
$ updatedb
followed by:
$ locate libphp4 | grep so
If nothing there, do you see "mod_php4.c" when you run this:
$ which httpd -l | grep php
Find your apache error_log, do this:
$ tail -f /path/to/apache/error_log
Then in another shell start apache:
$ which apachectl start
Does the "tail" window say anything at _all_?
We need more information..
--
-Brian Clark | PGP is spoken here: 0xE4D0C7C8
Please, DO NOT carbon copy me on list replies.