undefined symbol: uncompress
| From: | David Jackson | Date: | Sun, 27 Jan 2002 19:11:38 +0000 |
| Subject: | undefined symbol: uncompress | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-82302@lists.php.net to get a copy of this message | ||
I've seen similar question in the archive, but here it goes?
Setup: Slackware-8.0, Apache-1.3.23, mysql-3.23.47-pc-linux-gnu-i686
Config options:
Apache: ./configure --prefix=/usr/local/www --with-modules=most
compiles and run fine.
MySQl from binaires run fine into /usr/local/mysql (set ld.so.conf to
correct value).
PHP-4.1.1: ./configure --with-apxs=/usr/local/www/bin/apxs
--with-mysql=/usr/local/mysql
cp php-ini-recommanded /usr/local/lib/php.ini
Added AddType statement to httpd.conf
Results in following error when I try to start Apache:
Syntax error on line 236 of /usr/local/www/conf/httpd.conf:
Cannot load /usr/local/www/libexec/libphp4.so into server:
/usr/local/www/libexec/libphp4.so: undefined symbol: uncompress
Line 236 of http.conf:
LoadModule php4_module libexec/libphp4.so
Thanks for you help.
David Jackson