Re: undefined symbol: uncompress
| From: | Miles Thompson | Date: | Sun, 27 Jan 2002 23:44:49 +0000 |
| Subject: | Re: undefined symbol: uncompress | ||
| References: | 1 2 3 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-82331@lists.php.net to get a copy of this message | ||
Try it t wo ways ...
1. w/o the with-mysql, run a script containing phpinfo() and see what it returns.
MySQL support is compiled in by default to a default location.
2. Check that the with-mysql parameter is correct. On one system I had a path that was
/usr/local/mysql/bin/mysql
and yes, that fina lmysql was a directory. It caused so me problems.
It would help if the error messages were clearer, but they're still better than Winows
GPF's.
Miles Thompson
On Sunday 27 January 2002 03:50 pm, David Jackson wrote:
> Mike --
> Thanks for you reply, I made the changes an am stilling getting the same
> error?
> On the other hand if I compile PHP with out specifing mysql home. I
> don't get the error.
>
> David Jackson
>
> Miles Thompson wrote:
> > Add the path to libphp4.so to the file /etc/ld.conf.so
> > and run ldconfig
> >
> > or
> >
> > copy libphp4.so to the libexec directory found beneath the main apach
> > directory. It's most likely in the libs directory of your php source
> > directory.
> >
> > The second way is probably the best.
> >
> > HTH - Miles Thompson
> >
> > On Sunday 27 January 2002 03:11 pm, David Jackson wrote:
> > > I've seen similar question in the archive, but here it goes?
> > > Setup: Slackware-8.0, Apache-1.3.23, mysql-3.23.47-pc-linux-gnu-i686
> > > Config options:
> > > Apache: ./configure --prefix=/usr/local/www --with-modules=most
> > > compiles and run fine.
> > >
> > > MySQl from binaires run fine into /usr/local/mysql (set ld.so.conf to
> > > correct value).
> > >
> > > PHP-4.1.1: ./configure --with-apxs=/usr/local/www/bin/apxs
> > > --with-mysql=/usr/local/mysql
> > > cp php-ini-recommanded /usr/local/lib/php.ini
> > > Added AddType statement to httpd.conf
> > >
> > >
> > > Results in following error when I try to start Apache:
> > >
> > > Syntax error on line 236 of /usr/local/www/conf/httpd.conf:
> > > Cannot load /usr/local/www/libexec/libphp4.so into server:
> > > /usr/local/www/libexec/libphp4.so: undefined symbol: uncompress
> > >
> > > Line 236 of http.conf:
> > > LoadModule php4_module libexec/libphp4.so
> > >
> > >
> > > Thanks for you help.
> > > David Jackson