Re: Re:

From: Date: Sat, 08 Jul 2006 08:29:45 +0000
Subject: Re: Re:
References: 1 2  Groups: php.gtk.dev 
Request: Send a blank email to php-gtk-dev+get-3208@lists.php.net to get a copy of this message
I know what the English plural looks like. The fact is that you took a function that has a C name of "gtk_item_factories_path_delete" and put it into GtkItemFactor(y), since there is no GtkItemFactor(ies). Since you already used up the "factor" part of the name, it shouldn't be in the method. -Andrei On Jul 7, 2006, at 10:46 PM, Christian Weiske wrote:
Andrei,
-(define-function item_factories_path_delete +(define-method factories_path_delete + (of-object "GtkItemFactory") (c-name "gtk_item_factories_path_delete")
The method should be called "path_delete", not "factories_path_delete".
No. The C function is called "...factorIES...", not "..factorY...". So it doesn't apply to a single factory instance - thus I let the "factories" in there. But if you think it's better without factories in front, I'll remove it. --Regards/MfG, Christian Weiske


« previous php.gtk.dev (#3208) next »