php4.0.6 with apache 1.3.19 and gd 1.8.4

From: Date: Sun, 26 Aug 2001 22:15:06 +0000
Subject: php4.0.6 with apache 1.3.19 and gd 1.8.4
Groups: php.install 
Request: Send a blank email to php-install+get-4088@lists.php.net to get a copy of this message
I was trying to add the gd library to my server, and it seems things went wrong somewhere. MySQL is previously installed and working. (/usr/local/mysql) Installed the gd library to /usr/local/gd - ok Installed php with config as: ./configure --with-mysql=/usr/local/mysql --with-config-file-path=/www/conf --with-apache=/usr/local/etc/httpd --enable-track-vars --with-gd=/usr/local /gd This worked fine. All paths are correct. Installed apache - config.status of install follows: ./configure \ "--with-layout=Apache" \ "--prefix=/usr/local/etc/httpd" \ "--sysconfdir=/www/conf" \ "--enable-module=rewrite" \ "--enable-module=status" \ "--enable-shared=max" \ "--activate-module=src/modules/php4/libphp4.a" \ "$@" This worked fine. Copied php.ini to specified /www/conf, configured httpd.conf with LoadModule php4_module libexec/libphp4.so AddModule mod_php4.c in correct locations. Attempt to start apache: [root@neo bin]# apachectl start Syntax error on line 223 of /www/conf/httpd.conf: Cannot load /usr/local/etc/httpd/libexec/libphp4.so into server: ld.so.1: /usr/local/etc/httpd/bin/httpd: fatal: relocation error: file /usr/local/etc/httpd/libexec/libphp4.so: symbol gdImageCreateFromWBMPCtx: referenced symbol not found ./apachectl start: httpd could not be started If I remove the php module lines, apachestarts fine. If I compile PHP without GD, both apache and PHP work properly, but the GD is throwing it all off. Any ideas? Thanks.

« previous php.install (#4088) next »