Re: php4.0.6 with apache 1.3.19 and gd 1.8.4
| From: | Yasuo Ohgaki | Date: | Mon, 27 Aug 2001 23:30:19 +0000 |
| Subject: | Re: php4.0.6 with apache 1.3.19 and gd 1.8.4 | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-4091@lists.php.net to get a copy of this message | ||
Ryan Briggs wrote:
*SNIP*
Attempt to start apache: [root@neo bin]# apachectl start Syntax error on line 223 of /www/conf/httpd.conf: Cannot load /usr/local/etc/httpd/libexec/libphp4.so into server: ld.so.1: /usr/local/etc/httpd/bin/httpd: fatal: relocation error: file /usr/local/etc/httpd/libexec/libphp4.so: symbol gdImageCreateFromWBMPCtx: referenced symbol not found ./apachectl start: httpd could not be startedIt seems your web server (PHP) couldn't find correct GD shared lib. Easiest way to compile with GD is link with static lib that you want. My server (PHP4.0.6/Apache1.3.20/gd1.8.3(or2.0.0)) work fine with shared lib though. If you want to link with shared lib, look for the lib and make sure PHP loads lib you want.(edit /etc/ld.so.conf, run ldconfig, specify lib location when you configure php, etc) My gd lib are located like this /usr/lib/libgd.so:0000d500 T gdImageCreateFromWBMPCtx /usr/lib/libgd.so.1:0000d500 T gdImageCreateFromWBMPCtx /usr/lib/libgd.so.1.8:0000d500 T gdImageCreateFromWBMPCtx /usr/lib/libgd.so.1.8.3:0000d500 T gdImageCreateFromWBMPCtx /usr/lib/libgd.so.2:00011d38 T gdImageCreateFromWBMPCtx /usr/lib/libgd.so.2.0.0:00011d38 T gdImageCreateFromWBMPCtx -- Yasuo Ohgaki