Re: fatal: relocation error
| From: | Marco Hainaut | Date: | Tue, 25 Sep 2001 08:44:38 +0000 |
| Subject: | Re: fatal: relocation error | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-4394@lists.php.net to get a copy of this message | ||
Hi Keith,
I think U must edit your httpd.conf file at line 205 and correct the path to the libphp4.so at the right place : try with :
LoadModule php4_module /usr/local/apache/libexec/libphp4.so
Regards
MArco
At 14:04 24/09/2001 -0700, Keith Fleming wrote:
When trying to start apache I receive the following error: Syntax error on line 205 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: ld.so.1: /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp4.so: symbol uncompress: referenced symbol not found /usr/local/apache/bin/apachectl start: httpd could not be started Line 205 = LoadModule php4_module libexec/libphp4.so If I comment this line out, then the web server starts just fine. Hardware: SPARC OS: Solaris 8 GCC: gcc version 2.95.3 20010315 APACHE INSTALL: ./configure \ "--prefix=/usr/local/apache" \ "--enable-module=so" \ "--with-layout=Apache" \ PHP INSTALL: ./configure \ "--with-apxs=/usr/local/apache/bin/apxs" \ "--enable-versioning" \ "--with-mysql=/usr/local/mysql" \ "--enable-track-vars" \ Any ideas of what my problem could be? Keith __________________________________________________ Do You Yahoo!? Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com -- PHP Install Mailing List (http://www.php.net/) To unsubscribe, e-mail: php-install-unsubscribe@lists.php.net For additional commands, e-mail: php-install-help@lists.php.net To contact the list administrators, e-mail: php-list-admin@lists.php.net