Re: libphp4 load problem: uncompress
| From: | Yasuo Ohgaki | Date: | Sat, 29 Sep 2001 09:29:22 +0000 |
| Subject: | Re: libphp4 load problem: uncompress | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-4437@lists.php.net to get a copy of this message | ||
Brian Jacobs wrote:
Hello, I'm trying to install PHP on Redhat 6.1, using DSO. I run /apachectl configtest and get error Syntax error on line 238 of /usr/local/apache_1.3.14/conf/httpd.conf: Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined symbol: uncompress The 'make install' didn't find and alter my httpd.conf for me, so I added these lines as the last entries in their sections: LoadModule php4_module /usr/lib/apache/libphp4.so AddModule mod_php4.c And I uncommented AddType application/x-httpd-php .phpMy system has libz.so:00003810 T uncompress (/usr/lib) Do you have one? Try "nm -o *.so | grep uncompress" in your lib dirs. -- Yasuo Ohgaki