Re: libphp4 load problem: uncompress

From: Date: Mon, 05 Nov 2001 18:38:46 +0000
Subject: Re: libphp4 load problem: uncompress
References: 1 2  Groups: php.install 
Request: Send a blank email to php-install+get-4855@lists.php.net to get a copy of this message
Hello Yasuo Ohgaki tks for your short answer to BVrians problem. I have this problem too, but I think its not so easy, because I have found with the nm command the libz.so:00004310 T uncompress in /usr/lib Now , I have installed as the wwwrun user and I ' am not sure if they only like the root installation. So one I need a little help to install the libphp4.so It is in the correct path tks Markus Eppler Yasuo Ohgaki wrote: > Brian Jacobs wrote: > > Hello, > > > > I'm trying to install PHP on Redhat 6.1, using DSO. > > > > I run > > /apachectl configtest > > > > and get error > > > > Syntax error on line 238 of /usr/local/apache_1.3.14/conf/httpd.conf: > > Cannot load /usr/lib/apache/libphp4.so into server: /usr/lib/apache/libphp4.so: undefined > > symbol: uncompress > > > > The 'make install' didn't find and alter my httpd.conf for me, so I added > > these lines as the last entries in their sections: > > > > LoadModule php4_module /usr/lib/apache/libphp4.so > > > > AddModule mod_php4.c > > > > And I uncommented > > AddType application/x-httpd-php .php > > > > My system has > > libz.so:00003810 T uncompress > (/usr/lib) > > Do you have one? > Try "nm -o *.so | grep uncompress" in your lib dirs. > > -- > Yasuo Ohgaki

« previous php.install (#4855) next »