MM save hanlder problem

From: Date: Thu, 07 Feb 2002 10:15:22 +0000
Subject: MM save hanlder problem
References: 1 2 3 4 5 6  Groups: php.install 
Request: Send a blank email to php-install+get-5952@lists.php.net to get a copy of this message
Rick Morris wrote:
*** Error code 1
Hi, patch is not applied correctly. Change directory to php4 source root. then patch -p0 < session.diff (Since file path in the patch is "ext/session/<some_file_name_here>") Then you should be able to compile w/o any warnings and errors. You need to change directory and use appropriate -p option depends on patch.
No, I was in the correct location, but session.diff was accidentally mangled somewhere between my mail prog and text editor. Tried it again and this time it compiled fine ;-). But, I am still not able to run Apache. Here is my configure statement: ./configure --prefix=/usr/local --with-mysql=/usr/local --with-pgsql --with- apxs=/usr/local/apache/bin/apxs --enable-shmop --with-zlib --enable-wddx -- enable-inline-optimization --x-includes=/usr/X11R6/ --x-libraries=/usr/X11R6 / --with-gd=/usr/local/ --enable-gd-native-ttf --with-jpeg-dir=/usr/local -- with-png-dir=/usr/local --with-xpm-dir=/usr/local --with-freetype-dir=/usr/l ocal --with-ttf --with-zlib-dir=shared --with-curl=/usr/local --with-xml --e nable-ftp --enable-sockets --enable-sysvsem --enable-sysvshm --with-mm --wit h-pear Whenever I try to run Apache, I get the response "httpd could not be started", and when I tail the error_log, I see this: PHP Fatal error: Unable to start session mm module in Unknown on line 0 If I do exactly the same config statement without the 'mm' directive, Apache runs fine. Maybe it's a FreeBSD problem. As I said before, I will also try this on my Slackware box. Any other suggestions? Thanks for the help,
Hmm. What is your session.save_path? MM files are now created under session.save_path. If it is invalid, mm save handler does not work. (UID of httpd process should be able to write) -- Yasuo Ohgaki _________________________________________________________ Do You Yahoo!? Get your free @yahoo.com address at http://mail.yahoo.com

« previous php.install (#5952) next »