Re: MM save hanlder problem
| From: | Yasuo Ohgaki | Date: | Fri, 08 Feb 2002 08:48:26 +0000 |
| Subject: | Re: MM save hanlder problem | ||
| References: | 1 2 3 4 5 6 7 8 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-5963@lists.php.net to get a copy of this message | ||
Could you do
./cvsclean
./buildconf
./configure <options>
make
again?
--
Yasuo Ohgaki
Rick Morris wrote:
----- Original Message ----- From: "Yasuo Ohgaki" <yasuo_ohgaki@yahoo.com> To: "Rick Morris" <rick@brainscraps.com> Cc: <php-install@lists.php.net> Sent: Thursday, February 07, 2002 5:15 AM Subject: [PHP-INST] MM save hanlder problem-- Yasuo Ohgaki _________________________________________________________ Do You Yahoo!? Get your free @yahoo.com address at http://mail.yahoo.comRick Morris wrote:mangledNo, I was in the correct location, but session.diff was accidentally*** Error code 1Hi, patch is not applied correctly. Change directory to php4 source root. then patch -p0 < session.diff (Since file path in the patch is "ext/session/<some_file_name_here>") Then you should be able to compile w/o any warnings and errors. You need to change directory and use appropriate -p option depends on patch.timesomewhere between my mail prog and text editor. Tried it again and this./configure --prefix=/usr/local --with-mysql=/usr/local --with-pgsql --with- pxs=/usr/local/apache/bin/apxs --enable-shmop --with-zlib --enable-wddx -- enable-inline-optimization --x-includes=/usr/X11R6/ --x-libraries=/usr/X11R6 / --with-gd=/usr/local/ --enable-gd-native-ttf --with-jpeg-dir=/usr/local -- with-png-dir=/usr/local --with-xpm-dir=/usr/local --with-freetype-dir=/usr/l ocal --with-ttf --with-zlib-dir=shared --with-curl=/usr/local --with-xml --e nable-ftp --enable-sockets --enable-sysvsem --enable-sysvshm --with-mm --witit compiled fine ;-). But, I am still not able to run Apache. Here is my configure statement:Apacheh-pear Whenever I try to run Apache, I get the response "httpd could not be started", and when I tail the error_log, I see this: PHP Fatal error: Unable to start session mm module in Unknown on line 0 If I do exactly the same config statement without the 'mm' directive,myruns fine. Maybe it's a FreeBSD problem. As I said before, I will also try this onI had session_save_path set to /var/php_session, which was writable by Apache UID. Now, when I try to recompile PHP with mm again, I get 1800/TSRM -g -O2 -prefer-pic -c internal_functions.c internal_functions.c:67: `phpext_ps_mm_ptr' undeclared here (not in a function) internal_functions.c:67: initializer element is not constant internal_functions.c:67: (near initialization for `php_builtin_extensions[16]') gmake[2]: *** [internal_functions.lo] Error 1 gmake[2]: Leaving directory `/usr/home/rick/snaps.php/php4-200202061800/main' gmake[1]: *** [all-recursive] Error 1Slackware box. Any other suggestions? Thanks for the help,Hmm. What is your session.save_path? MM files are now created under session.save_path. If it is invalid, mm save handler does not work. (UID of httpd process should be able to write)-- Yasuo Ohgaki _________________________________________________________ Do You Yahoo!? Get your free @yahoo.com address at http://mail.yahoo.com -- PHP Install Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php