Re: PHP 4.2.1 install problem
| From: | Rasmus Lerdorf | Date: | Sun, 19 May 2002 03:40:44 +0000 |
| Subject: | Re: PHP 4.2.1 install problem | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-7051@lists.php.net to get a copy of this message | ||
Apache 2 + PHP is not fully baked yet. There are many issues and it will
be a while. If you want something that works, use Apache 1.3.
-Rasmus
On Sun, 19 May 2002, Defryn NZ wrote:
> Hi There,
>
> I am new to PHP and Unix and I am getting install problems.
> I am using PHP 4.2.1 , Apache 2.0.36 and Freebsd 4.4
>
> I have installed apache from source first and that works fine
> After installation the httpd can be started
>
> I install php from source
>
> ./configure -prefix=/usr/local/apache/php -with-apxs2=/usr/local/apache/bin/
> apxs -with-config-file-path=/usr/local/apache/php -with-mysql=/usr/local/mys
> ql
>
> After running make and make install I try to start the httpd ./apachectl
> start
>
> This is what I get
>
> Syntax error on line 229 of /usr/local/apache/conf/httpd.conf
>
> Cannot load /usr/local/apache/modules/libphp4.so into server
> /usr/local/apache/modules/libphp4.so : Undefined symbol
> "pthread_getspecific"
> /usr/local/apache/bin/apachectl start : httpd could not be started
>
>
> I have the following in my conf file
>
> Under dynamic dhared object
> LoadModule php4_module modules/lib4php.so
>
> Under AddType
>
> AddType application/x-httpd-php .php
>
>
> What is going wrong? Any ideas?
>
> Cheers
>
>
>
>
> --
> PHP Install Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>