Re: PHP 4.2.1 install problem

From: Date: Fri, 07 Jun 2002 17:52:54 +0000
Subject: Re: PHP 4.2.1 install problem
References: 1  Groups: php.install 
Request: Send a blank email to php-install+get-7256@lists.php.net to get a copy of this message
Hello, I have exactly the same error after compiling it under Freebsd 4.5 but i do not agree with Rasmus since i have succesfuly instaled and have it running on Slackware 8.0. There must be something wron'g but what that is the question. Please keep me posted if you find a solution i will do the same. "Defryn Nz" <defryn@inspire.net.nz> wrote in message news:LPBBKPACOGKNOEANKODIOEHHCOAA.defryn@inspire.net.nz... > Hi There, > > I am new to PHP and Unix and I am getting install problems. > I am using PHP 4.2.1 , Apache 2.0.36 and Freebsd 4.4 > > I have installed apache from source first and that works fine > After installation the httpd can be started > > I install php from source > > ./configure -prefix=/usr/local/apache/php -with-apxs2=/usr/local/apache/bin/ > apxs -with-config-file-path=/usr/local/apache/php -with-mysql=/usr/local/mys > ql > > After running make and make install I try to start the httpd ./apachectl > start > > This is what I get > > Syntax error on line 229 of /usr/local/apache/conf/httpd.conf > > Cannot load /usr/local/apache/modules/libphp4.so into server > /usr/local/apache/modules/libphp4.so : Undefined symbol > "pthread_getspecific" > /usr/local/apache/bin/apachectl start : httpd could not be started > > > I have the following in my conf file > > Under dynamic dhared object > LoadModule php4_module modules/lib4php.so > > Under AddType > > AddType application/x-httpd-php .php > > > What is going wrong? Any ideas? > > Cheers > > >

« previous php.install (#7256) next »