Re: Proposal: Rename image functions
| From: | Rowan Collins | Date: | Sat, 04 Nov 2017 17:39:13 +0000 |
| Subject: | Re: Proposal: Rename image functions | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-101052@lists.php.net to get a copy of this message | ||
On 4 November 2017 16:40:56 GMT+00:00, Andreas Treichel <gmblar@gmail.com> wrote:
> The only
>exception is image2wbmp which is renamed to image_to_wbmp.
What is the difference between imagewbmp and image2wbmp? If we're going to rename things,
shouldn't that difference be made clearer? Or should we be looking to deprecate one of them
anyway?
In my opinion, IF we rename, which I'm not 100% sold on, then all the output functions should
have "_to_" in the name: image_to_gif, image_to_png, etc. Or perhaps some other infix,
like "_save_", or "_generate_", particularly if using "gd_" as the
prefix.
Regards,
--
Rowan Collins
[IMSoP]