Re: Proposal: Rename image functions
| From: | Peter Kokot | Date: | Sun, 05 Nov 2017 13:51:01 +0000 |
| Subject: | Re: Proposal: Rename image functions | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-101065@lists.php.net to get a copy of this message | ||
Hello all,
correct me if I'm wrong, but wouldn't be a good practice to follow the
currently set coding standards?
https://github.com/php/php-src/blob/master/CODING_STANDARDS
Good:
'foo_select_bar'
Bad:
'fooinsertbaz'
And therefore making aliases for all inconsistently named functions in
the core for the next PHP version (and furthermore removing other
conventions in future versions)? My preference is definitely camelCase
but that would break all other prevailing naming of functions with
underscores...