Re: [RFC] FFI - Foreign Function Interface
| From: | Marco Pivetta | Date: | Tue, 11 Dec 2018 15:42:25 +0000 |
| Subject: | Re: [RFC] FFI - Foreign Function Interface | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-103584@lists.php.net to get a copy of this message | ||
> People who don't know what FFI is, don't need it.
I think this is a very dangerous way of designing, writing and documenting
software.
I appreciate your efforts in pushing this forward, but please reconsider
when approaching the naming problematic, because this point of view is
extremely flawed.
Marco Pivetta
http://twitter.com/Ocramius
http://ocramius.github.com/
On Tue, Dec 11, 2018 at 4:37 PM Dmitry Stogov <dmitry@zend.com> wrote:
> Hi Marco,
>
>
> Some API and naming issues may be changed, e.g. FFI::array_type() was
> renamed to FFI::arrayType().
>
> Changing FFI into ForeignFunctionInterface looks, like an overhead.
> People who don't know what FFI is, don't need it.
>
>
> I surprised, there are no any problem reports...
>
> It seems, like few people on @internals tried it.
>
>
> Thanks. Dmitry.
>
>
>
>
> ------------------------------
> *From:* Marco Pivetta <ocramius@gmail.com>
> *Sent:* Thursday, December 6, 2018 7:26:57 PM
> *To:* Dmitry Stogov
> *Cc:* PHP Internals List
> *Subject:* Re: [PHP-DEV] [RFC] FFI - Foreign Function Interface
>
> Looks very interesting, especially for simplifying the landscape of
> extensions.
>
> Still, the amount of abbreviations and naming issues is quite huge: needs
> a lot of care on that end, IMO. Even just the name of the type
> (
FFI) can
> simply be expanded to ForeignFunctionInterface.
>
> Just my 2 cents.
>
> Marco Pivetta
>
> http://twitter.com/Ocramius
>
> http://ocramius.github.com/
>
>
> On Thu, Dec 6, 2018 at 4:54 PM Dmitry Stogov <dmitry@zend.com> wrote:
>
> Hi Internals,
>
>
> I would like to start discussion of FFI RFC
> https://wiki.php.net/rfc/ffi
>
>
> This extension allows calling C function and accessing C data structures
> in pure PHP.
>
> In conjunction with preloading it gives a possibility to write PHP
> extension in PHP itself.
>
> The extension was tested on attempt to build TensorFlow PHP binding.
>
>
> Thanks. Dmitry.
>
>