Re: [RFC] FFI - Foreign Function Interface

From: Date: Tue, 11 Dec 2018 18:33:23 +0000
Subject: Re: [RFC] FFI - Foreign Function Interface
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-103587@lists.php.net to get a copy of this message
On 06.12.2018 at 17:26, Marco Pivetta wrote: > Looks very interesting, especially for simplifying the landscape of > extensions. > > Still, the amount of abbreviations and naming issues is quite huge: needs a > lot of care on that end, IMO. Even just the name of the type > (FFI) can > simply be expanded to ForeignFunctionInterface. By the same reasoning, http_response_code() is a bad name, and should be changed to hyper_text_transfer_protocol_response_code(). Same for parse_url(), which should better be named parse_uniform_resource_locator(). ;) Don't get me wrong, I'm all for having self-explaining identifiers, but if within a given domain an abbreviation is *very* common, it makes not much sense to spell it out. And FFI is very common when interfacing to C from a scripting language. -- Christoph M. Becker

« previous php.internals (#103587) next »