Re: Deprecation ideas for PHP 8
| From: | Midori Koçak | Date: | Tue, 22 Jan 2019 21:27:58 +0000 |
| Subject: | Re: Deprecation ideas for PHP 8 | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-103782@lists.php.net to get a copy of this message | ||
Can we also add strange function names without any naming conventions to
this list? Without undersore: strcspn, With underscore: str_repeat, chain
of abrevs: strnatcasecmp. Similar namings do exist for array functions
either.
Cheers,
Midori
On Tue, 22 Jan 2019 at 22:22, Girgias <george.banyard@gmail.com> wrote:
> On Tue, 22 Jan 2019 at 21:48, Stephen Reay <php-lists@koalephant.com>
> wrote:
>
> >
> > > On 23 Jan 2019, at 03:34, Girgias <george.banyard@gmail.com> wrote:
> > > Classes/Objects functions:
> > >
> > > - is_a (use instanceof operator)
> > > - is_subclass_of (not exactly what it's purpose is but the instanceof
> > > operator SHOULD be a valid equivalence with another condition if the
> > same
> > > class must not be used)
> >
> > is_subclass_of allows checking string class names, instanceof (AFAIK)
> does
> > not.
> >
>
> Good catch, just checked and it's indead the case that instanceof can't
> check string class names:
> https://3v4l.org/DkMC4
>
> George P. Banyard
>