Re: Deprecation ideas for PHP 8
| From: | Yasuo Ohgaki | Date: | Tue, 22 Jan 2019 22:06:01 +0000 |
| Subject: | Re: Deprecation ideas for PHP 8 | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-103784@lists.php.net to get a copy of this message | ||
On Wed, Jan 23, 2019 at 6:28 AM Midori Koçak <mtkocak@gmail.com> wrote:
> Can we also add strange function names without any naming conventions to
> this list? Without undersore: strcspn, With underscore: str_repeat, chain
> of abrevs: strnatcasecmp. Similar namings do exist for array functions
> either.
>
Candidates are these
https://wiki.php.net/rfc/consistent_function_names
From previous discussion, I think it would be better to keep both PHP and
POSIX names.
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net