Re: [RFC] Deprecations for 7.4
| From: | Claude Pache | Date: | Mon, 08 Jul 2019 13:41:05 +0000 |
| Subject: | Re: [RFC] Deprecations for 7.4 | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-106171@lists.php.net to get a copy of this message | ||
The deprecation RFC lists
apache_request_headers(), because it is “an Apache-specific
name is also available in other SAPIs, even though it is also available under the SAPI-independent
name getallheaders()”.
Have you ever thought about making a more thorough and consistent change with other similar
functions, instead of just picking one particular function because it is the only one in its
category that has a documented alias? In five minutes, I’m thinking of the following obvious
things:
* using a less ambiguous name than getallheaders(), given the existence of both
apache_request_headers() and apache_response_headers();
* renaming all apache_*() functions that are available in other SAPI into a
SAPI-independent name;
* treating all nsapi_*() functions as well.
—Claude