Re: [RFC] Deprecations for 7.4
| From: | Nikita Popov | Date: | Mon, 08 Jul 2019 14:14:47 +0000 |
| Subject: | Re: [RFC] Deprecations for 7.4 | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-106175@lists.php.net to get a copy of this message | ||
On Mon, Jul 8, 2019 at 3:41 PM Claude Pache <claude.pache@gmail.com> wrote:
> The deprecation RFC lists
apache_request_headers(), because it
> is “an
> Apache-specific name is also available in other SAPIs, even though it is
> also available under the SAPI-independent name getallheaders()”.
>
> Have you ever thought about making a more thorough and consistent change
> with other similar functions, instead of just picking one particular
> function because it is the only one in its category that has a documented
> alias? In five minutes, I’m thinking of the following obvious things:
>
> * using a less ambiguous name than getallheaders(), given the
> existence
> of both apache_request_headers() and
> apache_response_headers();
>
> * renaming all apache_*() functions that are available in other
> SAPI
> into a SAPI-independent name;
>
> * treating all nsapi_*() functions as well.
>
Thanks for bringing this up. I agree with you, and have dropped
apache_request_headers() from this RFC. This clearly needs a more
comprehensive change. Note that nsapi no longer exists since PHP 7, but
litespeed also has its own variation of these functions as well.
Nikita