Re: [RFC] Amendments to Attributes

From: Date: Wed, 27 May 2020 22:05:30 +0000
Subject: Re: [RFC] Amendments to Attributes
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-110289@lists.php.net to get a copy of this message
It seems that the RFC was updated to use the Attributes namespace. I think this is a bad idea since we're reserving a generic namespace that we haven't even "soft" reserved. Also, the loss of fallback to global namespace is a turning point for me. Generally, I think we should instead do something like Rowan said: use namespaced classes only for implementations (e.g. \Attribute but \PHP\Deprecated). Best regards, Benas On Wed, May 20, 2020, 8:08 PM Benjamin Eberlei <kontakt@beberlei.de> wrote: > Hi everyone, > > the Attributes RFC was rather large already, so a few things were left open > or discussions during the vote have made us rethink a things. > > https://wiki.php.net/rfc/attribute_amendments > > These points are handled by the Amendments RFC to Attributes: > > 1. Proposing to add a grouped syntax <<Attr1, Attr2> > 2. Rename PhpAttribute to Attribute in global namespace (independent of the > namespace RFC) > 3. Add validation of attribute class targets, which internal attributes can > do, but userland can't > 4. Specification if an attribute is repeatable or not on the same > declaration and fail otherwise. > > Each of them is a rather small issue, so I hope its ok to aggregate all > four of them in a single RFC. Please let me know if it's not. > > greetings > Benjamin >

« previous php.internals (#110289) next »