Re: [RFC] \PHP namespace usage heuristics

From: Date: Sat, 27 Jun 2020 16:07:40 +0000
Subject: Re: [RFC] \PHP namespace usage heuristics
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-110746@lists.php.net to get a copy of this message
> On Jun 23, 2020, at 8:30 PM, Larry Garfield <larry@garfieldtech.com> wrote: > > Greetings, Internalians. > > There has been much talk of the \PHP namespace of late, including one unsuccessful RFC. In the > discussion, the pushback broke down into two main camps: > > * We should never namespace anything ever. > * We can namespace things but we need something more concrete than "RFCs can namespace > things if they feel like it." > > I can't do much about the former, but the latter is a solvable problem. To that end, Mark > Randall and I have put together a new RFC on the topic, based on a fruitful discussion in Room 11 a > few weeks ago to brainstorm what actual guidelines should be for what goes where. > > https://wiki.php.net/rfc/php_namespace_policy > > This proposal provides guidance to short circuit future subjective bikeshedding, while still > leaving some wiggle room for case-by-case evaluation as needed. That makes it different from prior > attempts that did not provide clear guidance for future RFC authors. > > The specific guidelines offered may or may not appeal to you; those are open to discussion > (within reason; we don't want to end up back in "do whatever" land as we know that > won't help), but the more important point is that clear guidelines are provided. > > Also of note, although it uses existing code to demonstrate where classes *would* go under this > plan it does not immediately move anything. Those are left for future RFCs that would have to stand > or fall on their own merit. It also provides for a very long grace period for any such transitions > to minimize disruption. > > The intent is to bring this proposal to a vote in time for 8.0's freeze one way or > another, even though it's unlikely to have any impact on 8.0 itself. It's still a > convenient deadline. > > *dons flame retardant suit* > This looks really good Larry. Very well thought-out. If I could vote it would be a definitive "Yes." -Mike

« previous php.internals (#110746) next »